阿里云Ubuntu服务器软件系统漏洞修复(一)

服务器系统用的是 Ubuntu, 在服务器出现问题的时候,我看到阿里云控制台上提示,有N多个Linux软件漏洞,我不可能一个一个去网上搜索解决方案,再说了这种事情我之前就查过,没有多少相关的解决方案,所以只能购买阿里云的安骑士服务,生成修复命令来解决。下面是各种漏洞的相关描述及修复命令:

  1. 漏洞名称:USN-3415-1: tcpdump vulnerabilities

    修复紧急:高
    首次发现时间:2019-02-27 06:11:51
    最近一次发现时间:2019-03-03 01:43:25
    漏洞说明:
    软件:tcpdump 4.5.1-2ubuntu1.2
    命中:tcpdump version less than 4.9.2-0ubuntu0.14.04.1
    路径:/usr/share/doc/tcpdump
    修复命令:apt-get update && apt-get install tcpdump --only-upgrade
    
  2. 漏洞名称 :USN-3506-1: rsync vulnerabilities

    修复紧急:高
    首次发现时间:2019-02-27 06:11:51
    最近一次发现时间:2019-03-03 01:43:29
    漏洞说明:
    软件:rsync 3.1.0-2ubuntu0.1
    命中:rsync version less than 3.1.0-2ubuntu0.3
    路径:/usr/bin/rsync
    修复命令:apt-get update && apt-get install rsync --only-upgrade
    
  3. 漏洞名称 :USN-3282-1: FreeType vulnerabilities

    修复紧急:高
    首次发现时间:2019-02-27 06:11:51
    最近一次发现时间:2019-03-03 01:43:29
    漏洞说明:
    软件:libfreetype6 2.5.2-1ubuntu2.5
    命中:libfreetype6 version less than 2.5.2-1ubuntu2.8
    路径:/usr/share/doc/libfreetype6
    修复命令:apt-get update && apt-get install libfreetype6 --only-upgrade
    
  4. 漏洞名称 :USN-3235-1: libxml2 vulnerabilities

    修复紧急:高
    首次发现时间:2019-03-01 07:29:52
    最近一次发现时间:2019-03-03 01:43:28
    漏洞说明:
    软件:libxml2 2.9.1+dfsg1-3ubuntu4.5
    命中:libxml2 version less than 2.9.1+dfsg1-3ubuntu4.9
    路径:/usr/share/lintian/overrides/libxml2
    修复命令:apt-get update && apt-get install libxml2 --only-upgrade
    
  5. 漏洞名称 :USN-3569-1: libvorbis vulnerabilities

    修复紧急:高
    首次发现时间:2019-02-27 06:11:51
    最近一次发现时间:2019-03-03 01:43:28
    漏洞说明:
    软件:libvorbis0a 1.3.2-1.3ubuntu1
    命中:libvorbis0a version less than 1.3.2-1.3ubuntu1.1
    路径:/usr/share/lintian/overrides/libvorbis0a
    修复命令:apt-get update && apt-get install libvorbis0a --only-upgrade
    
  6. 漏洞名称 :USN-3424-1: libxml2 vulnerabilities

    修复紧急:高
    首次发现时间:2019-02-27 06:11:51
    最近一次发现时间:2019-03-03 01:43:27
    漏洞说明:
    软件:libxml2 2.9.1+dfsg1-3ubuntu4.5
    命中:libxml2 version less than 2.9.1+dfsg1-3ubuntu4.10
    路径:/usr/share/lintian/overrides/libxml2
    修复命令:apt-get update && apt-get install libxml2 --only-upgrade
    
  7. 漏洞名称 :USN-3497-1: OpenJDK 7 vulnerabilities

    修复紧急:高
    首次发现时间:2019-02-27 06:11:51
    最近一次发现时间:2019-03-03 01:43:18
    漏洞说明:
    软件:openjdk-7-jre 7u91-2.6.3-0ubuntu0.14.04.1
    命中:openjdk-7-jre version less than 7u151-2.6.11-2ubuntu0.14.04.1
    路径:/usr/share/lintian/overrides/openjdk-7-jre
    修复命令:apt-get update && apt-get install openjdk-7-jre --only-upgrade
    
  8. 漏洞名称 :USN-3134-1: Python vulnerabilities

    修复紧急:高
    首次发现时间:2019-03-01 07:29:52
    最近一次发现时间:2019-03-03 01:43:27
    漏洞说明:
    软件:python2.7 2.7.6-8ubuntu0.2
    命中:python2.7 version less than 2.7.6-8ubuntu0.3
    路径:/usr/lib/python2.7
    修复命令:apt-get update && apt-get install python2.7 --only-upgrade
    
  9. 漏洞名称 :USN-3078-1: MySQL vulnerability

    修复紧急:高
    首次发现时间:2019-02-20 14:04:43
    最近一次发现时间:2019-03-03 01:43:26
    漏洞说明:
    软件:mysql-client-5.5 5.5.46-0ubuntu0.14.04.2
    命中:mysql-client-5.5 version less than 5.5.52-0ubuntu0.14.04.1
    路径:/usr/share/lintian/overrides/mysql-client-5.5
    修复命令:apt-get update && apt-get install mysql-client-5.5 --only-upgrade
    

10.漏洞名称 :USN-3271-1: Libxslt vulnerabilities

修复紧急:高
首次发现时间:2019-03-01 07:29:52
最近一次发现时间:2019-03-03 01:43:26
漏洞说明:
软件:libxslt1.1 1.1.28-2build1
命中:libxslt1.1 version less than 1.1.28-2ubuntu0.1
路径:/usr/share/lintian/overrides/libxslt1.1
修复命令:apt-get update && apt-get install libxslt1.1 --only-upgrade

11.漏洞名称 :USN-2964-1: OpenJDK 7 vulnerabilities

修复紧急:高
首次发现时间:2019-03-01 07:29:52
最近一次发现时间:2019-03-03 01:43:25
漏洞说明:
软件:openjdk-7-jre 7u91-2.6.3-0ubuntu0.14.04.1
命中:openjdk-7-jre version less than 7u151-2.6.11-2ubuntu0.14.04.1
路径:/usr/share/lintian/overrides/openjdk-7-jre
修复命令:apt-get update && apt-get install openjdk-7-jre --only-upgrade

12.漏洞名称 :USN-3396-1: OpenJDK 7 vulnerabilities

修复紧急:高
首次发现时间:2019-02-27 06:11:51
最近一次发现时间:2019-03-03 01:43:20
漏洞说明:
软件:openjdk-7-jre 7u91-2.6.3-0ubuntu0.14.04.1
命中:openjdk-7-jre version less than 7u151-2.6.11-0ubuntu1.14.04.1
路径:/usr/share/lintian/overrides/openjdk-7-jre
修复命令:apt-get update && apt-get install openjdk-7-jre --only-upgrade

13.漏洞名称 :USN-3600-1: PHP vulnerabilities

修复紧急:高
首次发现时间:2019-02-22 10:17:43
最近一次发现时间:2019-03-03 01:43:24
漏洞说明:
软件:php5 5.5.9+dfsg-1ubuntu4.14
命中:php5 version less than 5.5.9+dfsg-1ubuntu4.24
路径:/usr/share/reportbug/php5
修复命令:apt-get update && apt-get install php5 --only-upgrade

14.漏洞名称 :USN-3130-1: OpenJDK 7 vulnerabilities

修复紧急:高
首次发现时间:2019-03-01 07:29:52
最近一次发现时间:2019-03-03 01:43:24
漏洞说明:
软件:openjdk-7-jre 7u91-2.6.3-0ubuntu0.14.04.1
命中:openjdk-7-jre version less than 7u121-2.6.8-1ubuntu0.14.04.1
路径:/usr/share/lintian/overrides/openjdk-7-jre
修复命令:apt-get update && apt-get install openjdk-7-jre --only-upgrade

15.漏洞名称 :USN-2884-1: OpenJDK 7 vulnerabilities

修复紧急:高
首次发现时间:2019-03-01 07:29:52
最近一次发现时间:2019-03-03 01:43:23
漏洞说明:
软件:libicu52 52.1-3ubuntu0.4
命中:libicu52 version less than 52.1-3ubuntu0.5
路径:/usr/share/lintian/overrides/libicu52
软件:openjdk-7-jre 7u91-2.6.3-0ubuntu0.14.04.1
命中:openjdk-7-jre version less than 7u95-2.6.4-0ubuntu0.14.04.1
路径:/usr/share/lintian/overrides/openjdk-7-jre
修复命令:apt-get update && apt-get install libicu52 --only-upgrade
     apt-get update && apt-get install openjdk-7-jre --only-upgrade
Last modification:March 14th, 2019 at 01:21 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment